All Vulnerability Reports

CVE-2022-31691: Remote Code Execution via YAML editors in STS4 extensions for Eclipse and VSCode


Severity

Medium

Vendor

Spring by VMware

Description

Spring Tools 4 for Eclipse version 4.16.0 and below as well as VSCode extensions such as Spring Boot Tools, Concourse CI Pipeline Editor, Bosh Editor and Cloudfoundry Manifest YML Support version 1.39.0 and below all use Snakeyaml library for YAML editing support. This library allows for some special syntax in the YAML that under certain circumstances allows for potentially harmful remote code execution by the attacker.

Affected VMware Products and Versions

Severity is medium unless otherwise noted.

  • Spring Tools 4 for Eclipse: Spring Tool Suite
    • 4.0.0 - 4.16.0
  • VSCode Extension: Spring Boot Tools
    • 1.0.0 - 1.39.0
  • VSCode Extension: Concourse CI Pipeline Editor
    • 1.0.0 - 1.39.0
  • VSCode Extension: Bosh Editor
    • 1.0.0 - 1.39.0
  • VSCode Extension: Cloudfoundry Manifest YML Support
    • 1.0.0 - 1.39.0

Mitigation

Users of affected versions should apply the following mitigation. STS4 Eclipse should be upgraded to the version 4.16.1 or higher. VSCode extensions: Spring Boot Tools, Concourse CI Pipeline Editor, Bosh Editor, Cloudfoundry Manifest YML Support should be upgraded to the version 1.40.0 or higher. Releases that have fixed this issue include:

  • Eclipse: STS
    • 4.16.1
  • VSCode: Spring Boot Tools
    • 1.40.0
  • VSCode: Concourse CI Pipeline Editor
    • 1.40.0
  • VSCode: Bosh Editor
    • 1.40.0
  • VSCode: Cloudfoundry Manifest YML Support
    • 1.40.0

Credit

This issue was identified and responsibly reported by Zewei Zhang from NSFOCUS TIANJI Lab

References

History

2022-11-03: Initial vulnerability report published.