All Vulnerability Reports

CVE-2022-22978: Authorization Bypass in RegexRequestMatcher


Severity

High

Vendor

Spring by VMware

Description

In Spring Security versions 5.5.6 and 5.6.3 and older unsupported versions, RegexRequestMatcher can easily be misconfigured to be bypassed on some servlet containers.

Applications using RegexRequestMatcher with `.` in the regular expression are possibly vulnerable to an authorization bypass.

Affected VMware Products and Versions

Severity is high unless otherwise noted.

Applications using RegexRequestMatcher with a regular expression that contains `.` are likely vulnerable to an authorization bypass for versions:

  • Spring Security
    • 5.5.x prior to 5.5.7
    • 5.6.x prior to 5.6.4
    • Earlier unsupported versions

Mitigation

Users should update to a version that includes fixes. 5.5.x users should upgrade to 5.5.7 or greater. 5.6.x users should upgrade to 5.6.4 or greater. Releases that have fixed this issue include:

  • Spring Security
    • 5.5.7+
    • 5.6.4+
    • 5.7+

Credit

This vulnerability was discovered and responsibly reported by Hiroki Nishino, Toshiki Sasazaki, Yoshinori Hayashi, and Jonghwan Kim from LINE Corporation.

References

History

2022-05-16: Initial vulnerability report published.