All Vulnerability Reports

CVE-2022-22969: Denial-of-Service (DoS) in spring-security-oauth2


Severity

Critical

Vendor

Spring by VMware

Description

Spring Security OAuth versions 2.5.x prior to 2.5.2 and older unsupported versions are susceptible to a Denial-of-Service (DoS) attack via the initiation of the Authorization Request in an OAuth 2.0 Client application. A malicious user or attacker can send multiple requests initiating the Authorization Request for the Authorization Code Grant, which has the potential of exhausting system resources using a single session. This vulnerability exposes OAuth 2.0 Client applications only.

Affected VMware Products and Versions

Severity is critical unless otherwise noted.

  • Spring Security OAuth
    • 2.5.x prior to 2.5.2
    • Older, unsupported versions

Mitigation

Users of affected versions should upgrade to the following versions:

  • Spring Security OAuth
    • 2.5.2+

Credit

This issue was identified and responsibly reported by Macchinetta/TERASOLUNA Framework Development Team.

References

History

2022-04-21: Initial vulnerability report published.