All Vulnerability Reports

CVE-2022-22950: Spring Expression DoS Vulnerability


Severity

Medium

Vendor

Spring by VMware

Description

In Spring Framework versions 5.3.0 - 5.3.16, 5.2.0 - 5.2.19, and older unsupported versions, it is possible for a user to provide a specially crafted SpEL expression that may cause a denial of service condition.

Affected VMware Products and Versions

Severity is medium unless otherwise noted.

  • Spring Framework
    • 5.3.0 to 5.3.16
    • 5.2.0 to 5.2.19
    • Older, unsupported versions are also affected

Mitigation

Users of affected versions should apply the following mitigation: 5.3.x users should upgrade to 5.3.17+. 5.2.x users should upgrade to 5.2.20+. No other steps are necessary. Releases that have fixed this issue include:

  • Spring Framework
    • 5.3.17+
    • 5.2.20+

Credit

This vulnerability was initially discovered and responsibly reported by 4ra1n.

References

History

2022-03-28: Initial vulnerability report published.
2022-04-05: Clarification that fix was backported to Spring Framework 5.2.20.