All Vulnerability Reports

CVE-2021-22096: Log Injection in Spring Framework


Severity

Medium

Vendor

Spring by VMware

Description

In Spring Framework versions 5.3.0 - 5.3.10, 5.2.0 - 5.2.17, and older unsupported versions, it is possible for a user to provide malicious input to cause the insertion of additional log entries.

Affected VMware Products and Versions

Severity is medium unless otherwise noted.

  • Spring Framework
    • 5.3.0 to 5.3.10
    • 5.2.0 to 5.2.17
    • Older, unsupported versions are also affected
Mitigation

Users of affected versions should apply the following mitigation: 5.3.x users should upgrade to 5.3.12+, 5.2.x users should upgrade to 5.2.18+. No other steps are necessary. Note: 5.3.11 also contains the mitigation but has another major regression. Releases that have fixed this issue include:

  • Spring Framework
    • 5.3.12+
    • 5.2.18+
Credit

This vulnerability was initially discovered and responsibly reported by Dennis Kennedy.

References
History

2021-10-26: Initial vulnerability report published.