All Vulnerability Reports

USN-4968-1: LZ4 vulnerability


Severity

Medium

Vendor

VMware Tanzu

Versions Affected
  • Canonical Ubuntu 18.04
Description

It was discovered that LZ4 incorrectly handled certain memory operations. If a user or automated system were tricked into uncompressing a specially- crafted LZ4 file, a remote attacker could use this issue to cause LZ4 to crash, resulting in a denial of service, or possibly execute arbitrary code.

CVEs contained in this USN include: CVE-2021-3520

Affected VMware Products and Versions

Severity is medium unless otherwise noted.

  • Platform Automation Toolkit
    • 4.4.x versions prior to 4.4.22
    • 5.0.x versions prior to 5.0.16
  • Isolation Segment
    • 2.7.x versions prior to 2.7.33
    • 2.8.x versions prior to 2.8.27
    • 2.9.x versions prior to 2.9.21
    • 2.10.x versions prior to 2.10.13
    • 2.11.x versions prior to 2.11.2
  • VMware Tanzu Application Service for VMs
    • 2.7.x versions prior to 2.7.34
    • 2.8.x versions prior to 2.8.28
    • 2.9.x versions prior to 2.9.22
    • 2.10.x versions prior to 2.10.14
    • 2.11.x versions prior to 2.11.3
Mitigation

Users of affected products are strongly encouraged to follow the mitigation below. On the Tanzu Network product page for each release, check the Depends On section and/or Release Notes for this information. Releases that have fixed this issue include:

  • Platform Automation Toolkit
    • 4.4.22
    • 5.0.16
  • Isolation Segment
    • 2.7.33
    • 2.8.27
    • 2.9.21
    • 2.10.13
    • 2.11.2
  • VMware Tanzu Application Service for VMs
    • 2.7.34
    • 2.8.28
    • 2.9.22
    • 2.10.14
    • 2.11.3
References
History

2021-09-13: Initial vulnerability report published.