All Vulnerability Reports

USN-4891-1: OpenSSL vulnerability


Severity

High

Vendor

VMware Tanzu

Versions Affected
  • Canonical Ubuntu 18.04
Description

It was discovered that OpenSSL incorrectly handled certain renegotiation ClientHello messages. A remote attacker could use this issue to cause OpenSSL to crash, resulting in a denial of service, or possibly execute arbitrary code.

CVEs contained in this USN include: CVE-2021-3449

Affected VMware Products and Versions

Severity is high unless otherwise noted.

  • Platform Automation Toolkit
    • 4.4.x versions prior to 4.4.22
    • 5.0.x versions prior to 5.0.16
  • Isolation Segment
    • 2.7.x versions prior to 2.7.32
    • 2.8.x versions prior to 2.8.26
    • 2.9.x versions prior to 2.9.20
    • 2.10.x versions prior to 2.10.12
    • 2.11.x versions prior to 2.11.1
  • VMware Tanzu Application Service for VMs
    • 2.7.x versions prior to 2.7.33
    • 2.8.x versions prior to 2.8.27
    • 2.9.x versions prior to 2.9.21
    • 2.10.x versions prior to 2.10.13
    • 2.11.x versions prior to 2.11.1
Mitigation

Users of affected products are strongly encouraged to follow the mitigation below. On the Tanzu Network product page for each release, check the Depends On section and/or Release Notes for this information. Releases that have fixed this issue include:

  • Platform Automation Toolkit
    • 4.4.22
    • 5.0.16
  • Isolation Segment
    • 2.7.32
    • 2.8.26
    • 2.9.20
    • 2.10.12
    • 2.11.1
  • VMware Tanzu Application Service for VMs
    • 2.7.33
    • 2.8.27
    • 2.9.21
    • 2.10.13
    • 2.11.1
References
History

2021-09-13: Initial vulnerability report published.