All Vulnerability Reports

USN-4705-1: Sudo vulnerabilities


Severity

High

Vendor

VMware Tanzu

Versions Affected
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04
Description

It was discovered that Sudo incorrectly handled memory when parsing command lines. A local attacker could possibly use this issue to obtain unintended access to the administrator account. (CVE-2021-3156)

It was discovered that the Sudo sudoedit utility incorrectly handled checking directory permissions. A local attacker could possibly use this issue to bypass file permissions and determine if a directory exists or not. (CVE-2021-23239)

CVEs contained in this USN include: CVE-2021-3156, CVE-2021-23239

Affected VMware Products and Versions

Severity is high unless otherwise noted.

Vulnerable Cloud Foundry components individually listed here.

Impacted stemcells may be updated independently of upgrading Tanzu Application Service or Isolation Segment.

  • Tanzu Greenplum for Kubernetes
    • All versions prior to 2.0.0
  • Isolation Segment
    • 2.7.x versions prior to 2.7.30, or later versions with Xenial Stemcells prior to 456.135
    • 2.8.x versions prior to 2.8.24, or later versions with Xenial Stemcells prior to 621.99
    • 2.9.x versions prior to 2.9.18, or later versions with Xenial Stemcells prior to 621.99
    • 2.10.x versions prior to 2.10.10, or later versions with Xenial Stemcells prior to 621.99
  • Operations Manager
    • 2.7 versions prior to 2.7.29
    • 2.9 versions prior to 2.9.17
    • 2.10 versions prior to 2.10.6
  • VMware Tanzu Application Service for VMs
    • 2.7.x versions prior to 2.7.31, or later versions with Xenial Stemcells prior to 456.135
    • 2.8.x versions prior to 2.8.25, or later versions with Xenial Stemcells prior to 621.99
    • 2.9.x versions prior to 2.9.19, or later versions with Xenial Stemcells prior to 621.99
    • 2.10.x versions prior to 2.10.11, or later versions with Xenial Stemcells prior to 621.99
Mitigation

Users of affected products are strongly encouraged to follow the mitigation below. The Cloud Foundry security team recommends upgrading the affected OSS components listed here if applicable. Upgrade VMware Tanzu products that use earlier versions of CF components to new Tanzu releases using new versions linked above. On the Tanzu Network product page for each release, check the Depends On section and/or Release Notes for this information. Releases that have fixed this issue include:

  • Tanzu Greenplum for Kubernetes
    • 2.0.0
  • Isolation Segment
    • 2.7.30, and upgrade Xenial Stemcells to 456.135 or greater
    • 2.8.24, and upgrade Xenial Stemcells to 621.99 or greater
    • 2.9.18, and upgrade Xenial Stemcells to 621.99 or greater
    • 2.10.10, and upgrade Xenial Stemcells to 621.99 or greater
  • Operations Manager
    • 2.7.29
    • 2.9.17
    • 2.10.6
  • VMware Tanzu Application Service for VMs
    • 2.7.31, and upgrade Xenial Stemcells to 456.135 or greater
    • 2.8.25, and upgrade Xenial Stemcells to 621.99 or greater
    • 2.9.19, and upgrade Xenial Stemcells to 621.99 or greater
    • 2.10.11, and upgrade Xenial Stemcells to 621.99 or greater
References
History

2021-03-01: Initial vulnerability report published.