All Vulnerability Reports

USN-4692-1: tar vulnerabilities


Severity

Low

Vendor

VMware Tanzu

Versions Affected
  • Canonical Ubuntu 14.04
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04
Description

Chris Siebenmann discovered that tar incorrectly handled extracting files resized during extraction when invoked with the --sparse flag. An attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 12.04 ESM, Ubuntu 14.04 ESM, Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-2018-20482)

Daniel Axtens discovered that tar incorrectly handled certain malformed tar files. If a user or automated system were tricked into processing a specially crafted tar archive, a remote attacker could use this issue to cause tar to crash, resulting in a denial of service. (CVE-2019-9923)

CVEs contained in this USN include: CVE-2018-20482, CVE-2019-9923

Affected VMware Products and Versions

Severity is low unless otherwise noted.

Vulnerable Cloud Foundry components individually listed here.

Impacted stemcells may be updated independently of upgrading Tanzu Application Service or Isolation Segment.

  • Platform Automation Toolkit
    • 4.4.x versions prior to 4.4.19
    • 5.0.x versions prior to 5.0.13
  • Tanzu Greenplum for Kubernetes
    • All versions prior to 2.0.0
  • Isolation Segment
    • 2.7.x versions prior to 2.7.30, or later versions with Xenial Stemcells prior to 456.133
    • 2.8.x versions prior to 2.8.24, or later versions with Xenial Stemcells prior to 621.97
    • 2.9.x versions prior to 2.9.18, or later versions with Xenial Stemcells prior to 621.97
    • 2.10.x versions prior to 2.10.10, or later versions with Xenial Stemcells prior to 621.97
  • Operations Manager
    • 2.7 versions prior to 2.7.28
    • 2.9 versions prior to 2.9.16
    • 2.10 versions prior to 2.10.5
  • VMware Tanzu Application Service for VMs
    • 2.7.x versions prior to 2.7.31, or later versions with Xenial Stemcells prior to 456.133
    • 2.8.x versions prior to 2.8.25, or later versions with Xenial Stemcells prior to 621.97
    • 2.9.x versions prior to 2.9.19, or later versions with Xenial Stemcells prior to 621.97
    • 2.10.x versions prior to 2.10.11, or later versions with Xenial Stemcells prior to 621.97
Mitigation

Users of affected products are strongly encouraged to follow the mitigation below. The Cloud Foundry security team recommends upgrading the affected OSS components listed here if applicable. Upgrade VMware Tanzu products that use earlier versions of CF components to new Tanzu releases using new versions linked above. On the Tanzu Network product page for each release, check the Depends On section and/or Release Notes for this information. Releases that have fixed this issue include:

  • Platform Automation Toolkit
    • 4.4.19
    • 5.0.13
  • Tanzu Greenplum for Kubernetes
    • 2.0.0
  • Isolation Segment
    • 2.7.30, and upgrade Xenial Stemcells to 456.133 or greater
    • 2.8.24, and upgrade Xenial Stemcells to 621.97 or greater
    • 2.9.18, and upgrade Xenial Stemcells to 621.97 or greater
    • 2.10.10, and upgrade Xenial Stemcells to 621.97 or greater
  • Operations Manager
    • 2.7.28
    • 2.9.16
    • 2.10.5
  • VMware Tanzu Application Service for VMs
    • 2.7.31, and upgrade Xenial Stemcells to 456.133 or greater
    • 2.8.25, and upgrade Xenial Stemcells to 621.97 or greater
    • 2.9.19, and upgrade Xenial Stemcells to 621.97 or greater
    • 2.10.11, and upgrade Xenial Stemcells to 621.97 or greater
References
History

2021-03-01: Initial vulnerability report published.