All Vulnerability Reports

USN-4676-1: OpenEXR vulnerabilities


Severity

Medium

Vendor

VMware Tanzu

Versions Affected
  • Canonical Ubuntu 18.04
Description

It was discovered that OpenEXR incorrectly handled certain malformed EXR image files. If a user were tricked into opening a crafted EXR image file, a remote attacker could cause a denial of service, or possibly execute arbitrary code.

CVEs contained in this USN include: CVE-2020-16588, CVE-2020-16587, CVE-2020-16589

Affected VMware Products and Versions

Severity is medium unless otherwise noted.

Vulnerable Cloud Foundry components individually listed here.

  • Isolation Segment
    • 2.7.x versions prior to 2.7.30
    • 2.8.x versions prior to 2.8.24
    • 2.9.x versions prior to 2.9.18
    • 2.10.x versions prior to 2.10.10
  • VMware Tanzu Application Service for VMs
    • 2.7.x versions prior to 2.7.31
    • 2.8.x versions prior to 2.8.25
    • 2.9.x versions prior to 2.9.19
    • 2.10.x versions prior to 2.10.11
Mitigation

Users of affected products are strongly encouraged to follow the mitigation below. The Cloud Foundry security team recommends upgrading the affected OSS components listed here if applicable. Upgrade VMware Tanzu products that use earlier versions of CF components to new Tanzu releases using new versions linked above. On the Tanzu Network product page for each release, check the Depends On section and/or Release Notes for this information. Releases that have fixed this issue include:

  • Isolation Segment
    • 2.7.30
    • 2.8.24
    • 2.9.18
    • 2.10.10
  • VMware Tanzu Application Service for VMs
    • 2.7.31
    • 2.8.25
    • 2.9.19
    • 2.10.11
References
History

2021-03-01: Initial vulnerability report published.