All Vulnerability Reports

USN-4613-1: python-cryptography vulnerability


Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04
Description

Hubert Kario discovered that python-cryptography incorrectly handled certain decryption. An attacker could possibly use this issue to expose sensitive information.

CVEs contained in this USN include: CVE-2020-25659

Affected VMware Products and Versions

Severity is medium unless otherwise noted.

  • Operations Manager
    • 2.7 versions prior to 2.7.26
    • 2.9 versions prior to 2.9.13
    • 2.10 versions prior to 2.10.3
  • Platform Automation Toolkit
    • 4.0.x versions prior to 4.0.13
    • 4.1.x versions prior to 4.1.13
    • 4.2.x versions prior to 4.2.8
    • 4.3.x versions prior to 4.3.5
Mitigation

Users of affected products are strongly encouraged to follow the mitigation below. Upgrade VMware Tanzu products that use earlier versions of CF components to new Tanzu releases using new versions linked above. On the Tanzu Network product page for each release, check the Depends On section and/or Release Notes for this information. Releases that have fixed this issue include:

  • Operations Manager
    • 2.7.26
    • 2.9.13
    • 2.10.3
  • Platform Automation Toolkit
    • 4.0.13
    • 4.1.13
    • 4.2.8
    • 4.3.5
References
History

2020-12-11: Initial vulnerability report published.