All Vulnerability Reports

USN-4269-1: systemd vulnerabilities


Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04
Description

It was discovered that systemd incorrectly handled certain PIDFile files. A local attacker could possibly use this issue to trick systemd into killing privileged processes. This issue only affected Ubuntu 16.04 LTS. (CVE-2018-16888)

It was discovered that systemd incorrectly handled certain udevadm trigger commands. A local attacker could possibly use this issue to cause systemd to consume resources, leading to a denial of service. (CVE-2019-20386)

Jann Horn discovered that systemd incorrectly handled services that use the DynamicUser property. A local attacker could possibly use this issue to access resources owned by a different service in the future. This issue only affected Ubuntu 18.04 LTS. (CVE-2019-3843, CVE-2019-3844)

Tavis Ormandy discovered that systemd incorrectly handled certain Polkit queries. A local attacker could use this issue to cause systemd to crash, resulting in a denial of service, or possibly execute arbitrary code and escalate privileges. (CVE-2020-1712)

CVEs contained in this USN include: CVE-2018-16888, CVE-2019-3843, CVE-2019-3844, CVE-2019-20386, CVE-2020-1712

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

Vulnerable Cloud Foundry components individually listed here.

Impacted stemcells may be updated independently of upgrading Pivotal Application Service or PCF Isolation Segment.

  • Operations Manager
    • 2.5.x versions prior to 2.5.30
    • 2.6.x versions prior to 2.6.23
    • 2.7.x versions prior to 2.7.13
    • 2.8.x versions prior to 2.8.4
  • Pivotal Application Service (PAS)
    • 2.6.x versions prior to 2.6.16
    • 2.7.x versions prior to 2.7.10
    • 2.8.x versions prior to 2.8.4
  • Pivotal Greenplum for Kubernetes
    • All versions prior to 1.12.0
  • Pivotal Isolation Segment
    • 2.6.x versions prior to 2.6.15
    • 2.7.x versions prior to 2.7.10
    • 2.8.x versions prior to 2.8.4
Mitigation

Users of affected products are strongly encouraged to follow the mitigation below. The Cloud Foundry security team recommends upgrading the affected OSS components listed here if applicable. Upgrade Pivotal products that use earlier versions of CF components to new Pivotal releases using new versions linked above. On the Pivotal Network product page for each release, check the Depends On section and/or Release Notes for this information. Releases that have fixed this issue include:

  • Operations Manager
    • 2.5.30
    • 2.6.23
    • 2.7.13
    • 2.8.4
  • Pivotal Application Service (PAS)
    • 2.6.16
    • 2.7.10
    • 2.8.4
  • Pivotal Greenplum for Kubernetes
    • 1.12.0
  • Pivotal Isolation Segment
    • 2.6.15
    • 2.7.10
    • 2.8.4
References
History

2020-02-05: Initial vulnerability report published.