All Vulnerability Reports

USN-4247-2: python-apt regression


Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected
  • Canonical Ubuntu 16.04
Description

USN-4247-1 fixed vulnerabilities in python-apt. The updated packages caused a regression when attempting to upgrade to a new Ubuntu release. This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

It was discovered that python-apt would still use MD5 hashes to validate certain downloaded packages. If a remote attacker were able to perform a man-in-the-middle attack, this flaw could potentially be used to install altered packages. (CVE-2019-15795)

It was discovered that python-apt could install packages from untrusted repositories, contrary to expectations. (CVE-2019-15796)

CVEs contained in this USN include: CVE-2019-15795, CVE-2019-15796

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

Vulnerable Cloud Foundry components individually listed here.

Impacted stemcells may be updated independently of upgrading Pivotal Application Service or PCF Isolation Segment.

  • Operations Manager
    • 2.5.x versions prior to 2.5.29
    • 2.6.x versions prior to 2.6.22
    • 2.7.x versions prior to 2.7.12
    • 2.8.x versions prior to 2.8.4
  • Pivotal Application Service (PAS)
    • 2.5.x versions prior to 2.5.21
    • 2.6.x versions prior to 2.6.16
    • 2.7.x versions prior to 2.7.10
    • 2.8.x versions prior to 2.8.4
  • Pivotal Greenplum for Kubernetes
    • All versions prior to 1.12.0
  • Pivotal Isolation Segment
    • 2.6.x versions prior to 2.6.15
    • 2.7.x versions prior to 2.7.10
    • 2.8.x versions prior to 2.8.4
Mitigation

Users of affected products are strongly encouraged to follow the mitigation below. The Cloud Foundry security team recommends upgrading the affected OSS components listed here if applicable. Upgrade Pivotal products that use earlier versions of CF components to new Pivotal releases using new versions linked above. On the Pivotal Network product page for each release, check the Depends On section and/or Release Notes for this information. Releases that have fixed this issue include:

  • Operations Manager
    • 2.5.29
    • 2.6.22
    • 2.7.12
    • 2.8.4
  • Pivotal Application Service (PAS)
    • 2.5.21
    • 2.6.16
    • 2.7.10
    • 2.8.4
  • Pivotal Greenplum for Kubernetes
    • 1.12.0
  • Pivotal Isolation Segment
    • 2.6.15
    • 2.7.10
    • 2.8.4
References
History

2020-01-22: Initial vulnerability report published.