All Vulnerability Reports

USN-4221-1: libpcap vulnerability


Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected
  • Canonical Ubuntu 14.04
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04
Description

It was discovered that libpcap did not properly validate PHB headers in some situations. An attacker could use this to cause a denial of service (memory exhaustion).

CVEs contained in this USN include: CVE-2019-15165

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

Vulnerable Cloud Foundry components individually listed here.

Impacted stemcells may be updated independently of upgrading Pivotal Application Service or PCF Isolation Segment.

  • Pivotal Application Service (PAS)
    • 2.5 versions prior to 2.5.19
    • 2.6 versions prior to 2.6.14
    • 2.7 versions prior to 2.7.8
    • 2.8 versions prior to 2.8.2
  • Pivotal Isolation Segment
    • 2.5 versions prior to 2.5.18
    • 2.6 versions prior to 2.6.13
    • 2.7 versions prior to 2.7.8
    • 2.8 versions prior to 2.8.2
  • Pivotal Operations Manager
    • 2.5 versions prior to 2.5.27
    • 2.6 versions prior to 2.6.20
    • 2.7 versions prior to 2.7.10
    • 2.8 versions prior to 2.8.1
Mitigation

Users of affected products are strongly encouraged to follow the mitigation below

  • The Cloud Foundry security team recommends upgrading the affected OSS components listed here if applicable.
  • Upgrade Pivotal products that use earlier versions of CF components to new Pivotal releases using new versions linked above. On the Pivotal Network product page for each release, check the Depends On section and/or Release Notes for this information.
  • Releases that have fixed this issue include:

  • Pivotal Application Service (PAS)
    • 2.5.19
    • 2.6.14
    • 2.7.8
    • 2.8.2
  • Pivotal Isolation Segment
    • 2.5.18
    • 2.6.13
    • 2.7.8
    • 2.8.2
  • Pivotal Operations Manager
    • 2.5.27
    • 2.6.20
    • 2.7.10
    • 2.8.1
References
History

2019-12-11: Initial vulnerability report published.