All Vulnerability Reports

CVE-2020-5416: TAS clusters with NGINX in front of them may be vulnerable to DoS


Severity

High

Vendor

VMware Tanzu

Description

VMware Tanzu Application Service for VMs and Isolation Segment, all versions prior 2.7.22, 2.8.x versions prior to 2.8.16, 2.9.x versions prior to 2.9.10, and 2.10.x versions prior to 2.10.2, consume a version of Cloud Foundry Routing (Gorouter) that, when used in a deployment with NGINX reverse proxies in front of the Gorouters, is potentially vulnerable to denial-of-service attacks in which an unauthenticated malicious attacker can send specially-crafted HTTP requests that may cause the Gorouters to be dropped from the NGINX backend pool.

Affected VMware Products and Versions

Severity is high unless otherwise noted.

  • Isolation Segment
    • All versions prior to 2.7.22
    • 2.8.x versions prior to 2.8.16
    • 2.9.x versions prior to 2.9.10
    • 2.10.x versions prior to 2.10.2
  • VMware Tanzu Application Service for VMs
    • All versions prior to 2.7.22
    • 2.8.x versions prior to 2.8.16
    • 2.9.x versions prior to 2.9.10
    • 2.10.x versions prior to 2.10.2
Mitigation

Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include:

  • Isolation Segment
    • 2.7.22
    • 2.8.16
    • 2.9.10
    • 2.10.2
  • VMware Tanzu Application Service for VMs
    • 2.7.22
    • 2.8.16
    • 2.9.10
    • 2.10.2
References
History

2020-09-01: Initial vulnerability report published.