All Vulnerability Reports

CVE-2020-5405: Directory Traversal with spring-cloud-config-server


Severity

High

Vendor

Spring by VMware

Description

Spring Cloud Config, versions 2.2.x prior to 2.2.2, versions 2.1.x prior to 2.1.7, and older unsupported versions allow applications to serve arbitrary configuration files through the spring-cloud-config-server module. A malicious user, or attacker, can send a request using a specially crafted URL that can lead a directory traversal attack.

Affected VMware Products and Versions

Severity is high unless otherwise noted.

Older unsupported versions are also affected.

  • Spring Cloud Config
    • 2.2.0 to 2.2.1
    • 2.1.0 to 2.1.6
Mitigation

Users of affected versions should apply the following mitigation: 2.2.x users should upgrade to 2.2.2, 2.1.x users should upgrade to 2.1.7.  Older versions should upgrade to a supported branch. There are no other mitigation steps necessary. Note that spring-cloud-config-server should only be available on internal networks to clients that require it and it should be secured with Spring Security, this limits exposure to this vulnerability to those with internal network access and those users with proper authentication. Releases that have fixed this issue include:

  • Spring Cloud Config
    • 2.2.2
    • 2.1.7
Credit

This issue was identified and responsibly reported by Yiming Xiang (phalaif0y@outlook.com at NSFOCUS Security Team).

References
History

2020-02-26: Initial vulnerability report published.