All Vulnerability Reports

USN-3990-1: urllib3 vulnerabilities


Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected
  • Canonical Ubuntu 16.04
Description

It was discovered that urllib3 incorrectly removed Authorization HTTP headers when handled cross-origin redirects. This could result in credentials being sent to unintended hosts. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS and Ubuntu 18.10. (CVE-2018-20060)

It was discovered that urllib3 incorrectly stripped certain characters from requests. A remote attacker could use this issue to perform CRLF injection. (CVE-2019-11236)

It was discovered that urllib3 incorrectly handled situations where a desired set of CA certificates were specified. This could result in certificates being accepted by the default CA certificates contrary to expectatons. This issue only affected Ubuntu 18.04 LTS, Ubuntu 18.10, and Ubuntu 19.04. (CVE-2019-11324)

CVEs contained in this USN include: CVE-2018-20060, CVE-2019-11236, CVE-2019-11324

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • Pivotal Operations Manager
    • 2.5.x versions prior to 2.5.5
    • 2.4.x versions prior to 2.4.12
    • 2.3.x versions prior to 2.3.19
  • Pivotal Greenplum for Kubernetes
    • All versions prior to 1.2.0
Mitigation

Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include:

  • Pivotal Operations Manager
    • 2.5.5
    • 2.4.12
    • 2.3.19
  • Pivotal Greenplum for Kubernetes
    • 1.2.0
References