All Vulnerability Reports

CVE-2022-22968: Spring Framework Data Binding Rules Vulnerability


Severity

Low

Vendor

Spring by VMware

Description

In Spring Framework versions 5.3.0 - 5.3.18, 5.2.0 - 5.2.20, and older unsupported versions, the patterns for disallowedFields on a DataBinder are case sensitive which means a field is not effectively protected unless it is listed with both upper and lower case for the first character of the field, including upper and lower case for the first character of all nested fields within the property path.

Affected VMware Products and Versions

Severity is low unless otherwise noted.

  • Spring Framework
    • 5.3.0 to 5.3.18
    • 5.2.0 to 5.2.20
    • Older, unsupported versions are also affected

Mitigation

Users of affected versions should apply the following mitigation: 5.3.x users should upgrade to 5.3.19+. 5.2.x users should upgrade to 5.2.21+. No other steps are necessary, but applications should also review their DataBinder configuration and more broadly their approach to data binding. For more details, please see Data Binding Model Design in the Spring Framework reference manual. Releases that have fixed this issue include:

  • Spring Framework
    • 5.3.19+
    • 5.2.21+

Credit

This vulnerability was discovered internally by the Spring Framework team and is a follow-up to CVE-2022-22965.

References

History

2022-04-13: Initial vulnerability report published.